Email delivery issues due to global Microsoft Outlook service outage

Incident Report for CIMcloud

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 08:53 EST

Monitoring

Microsoft claims to have resolved the issue in the early morning hours. Mail delivery may still be delayed as queues process and retries happen.
Posted Jan 23, 2026 - 07:40 EST

Identified

We are aware of and are monitoring a global service outage with Microsoft's Outlook mail services for business that started around 2:00 PM ET on Jan 22, 2026. For more information about the outage, see https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect.
Posted Jan 22, 2026 - 19:16 EST